30 December 2014

Lagi lagi error di eclipse gara gara update SDK Android

Muncul error di eclipse, lupa di capture, tapi saat mau di update komponen via eclipse gagal update dan ada dialog dibawah

 
Cannot complete the install because of a conflicting dependency.
  Software being installed: Android Development Tools 23.0.4.1468518 (com.android.ide.eclipse.adt.feature.feature.group 23.0.4.1468518)
  Software currently installed: Android Development Tools 20.0.3.v201208082019-427395 (com.android.ide.eclipse.adt.feature.group 20.0.3.v201208082019-427395)
  Only one of the following can be installed at once:
    ADT XML Overlay 23.0.4.1468518 (overlay.com.android.ide.eclipse.adt.overlay 23.0.4.1468518)
    ADT XML Overlay 20.0.3.v201208082019-427395 (overlay.com.android.ide.eclipse.adt.overlay 20.0.3.v201208082019-427395)
  Cannot satisfy dependency:
    From: Android Development Tools 23.0.4.1468518 (com.android.ide.eclipse.adt.feature.feature.group 23.0.4.1468518)
    To: overlay.com.android.ide.eclipse.adt.overlay [23.0.4.1468518]
  Cannot satisfy dependency:
    From: Android Development Tools 20.0.3.v201208082019-427395 (com.android.ide.eclipse.adt.feature.group 20.0.3.v201208082019-427395)
    To: overlay.com.android.ide.eclipse.adt.overlay [20.0.3.v201208082019-427395]



Solusi
1. uninstall komponen2 via help-about nya eclipse
2. install via help-install new software dengan link https://dl-ssl.google.com/android/eclipse/
3. uncheck “Contact all update sites during install to find required software”, karena bakal konflik

Link2 sumber info

http://stackoverflow.com/questions/24520230/error-while-updating-adt-23-0-0-in-eclipse

http://stackoverflow.com/questions/18483815/an-error-occurred-while-collecting-items-to-be-installed